Equity National Title - Unexpected outage - my.equitynational.com – Incident details

All systems operational

Unexpected outage - my.equitynational.com

Resolved
Major outage
Started almost 2 years agoLasted about 23 hours

Affected

my.equitynational.com

Major outage from 1:00 AM to 11:56 PM

Updates
  • Resolved
    Resolved

    The issue is resolved. Our website my.equitynational.com is functioning as intended.

  • Identified
    Identified

    IT - Outage (website) - Notification

    Impacted Service(s): my.equitynational.com

    Outage Start Date & Time: Saturday 12/10/2022 8:00 PM ET

    • An updated notice will be sent out when the website is functional again.

    FURTHER INFORMATION To request further information regarding this outage please contact the IT help desk.

    Email: helpdesk@equitynational.com