IT - Planned Maintenance (Citrix) - Notification
Scheduled for June 27, 2025 at 12:30 AM – 12:48 AM
Affects
Citrix
Under maintenance from 12:30 AM to 12:48 AM
Completed
June 27, 2025 at 12:48 AMCompleted
June 27, 2025 at 12:48 AMMaintenance has completed successfully.
In progress
June 27, 2025 at 12:30 AMIn progress
June 27, 2025 at 12:30 AMMaintenance is now in progress
Planned
June 27, 2025 at 12:30 AMPlanned
June 27, 2025 at 12:30 AMIT - Planned Maintenance (Citrix) - Notification
Impacted Service(s): Citrix
Scope of Work: Citrix NetScaler will be patched to resolve a vulnerability that was recently discovered.
Outage Window:
FURTHER INFORMATION To request further information regarding this outage please contact the IT help desk.
Email: helpdesk@equitynational.com